Video In Excerpts Twenty Fourteen

There is something peculiar about the default theme Twenty Fourteen!

So I created a function for Fourteen Extended to switch Twenty Fourteen to show excerpts including videos on the home page and it worked perfectly on my local server. But when I installed the plugin on a remote server it just didn’t work, I mean the videos just did not work – on some sites I got the link output in the content and on other sites I got a black space where the content should be.

Reworked the function multiple times and tested over and over again with the same results :-$….then I remember reading in the forum something about Twenty Fourteen and how it saves its transients and it clicked. It had to be that, transients needed to be flushed in order for the changes to take effect – but how do you flush them out so that you can start over again?

This has to me the most ridiculous way I’ve ever had to deal with a theme in order to get new settings to take effect and work as they should. So here’s how you get Twenty Fourteen to reset its transients (i.e. delete them).

For my purpose (get Fourteen Extended to work as intended) I changed all of the settings to their default values and saved – this returned Twenty Fourteen to almost its normal state. Remember we are working in the theme Customizer here – so lets get out and go to the plugins section where I deactivated Fourteen Extended.

I then went back in to the Customizer changed the sidebar menu so that I could save the settings again. After doing so I exited the customizer back in to the theme’s page where I proceeded to activate the Twenty Thirteen theme and then back in to the customizer, changed something in order to be able to save settings. At this point its important to visit the site’s front end and refresh it a couple of times by hitting the F5 key.

Return to the admin area and on to the themes page and reactivate Twenty Fourteen then visit the customizer, change something and save. Visit front end and refresh a couple of times then go back in to the Admin area and the plugins page where I activated the Fourteen Extended plugin before going back in to the Customizer.

Selected the desired options generated by the plugin, saved and exited the customizer and on to the front end – refreshed the site and voila, it worked. I now have the site set to excerpts with the first video showing up for the Video Post Formats. Take a look at the post below this one 🙂

So there you have it, that is how you get Twenty Fourteen to play nice with your desired settings.

There have been other reports of things not working or appearing as they should – I believe it is the same problem as outlined above that is causing the issues. So if for some reason a setting or a plugin does not seem to be working as advertised try the above before knocking on the theme’s or the relevant plugin’s forum doors.

If all else fails by all means drop by the forums and raise a thread where some of the wonderful volunteers will be more than happy to help.

2 thoughts on “Video In Excerpts Twenty Fourteen”

    1. Hello Mano,

      Navigate to the theme customizer under the Appearance section and click on the “TwentyFourteen Content Options” tab to expand it. then scroll down a little and you’ll see a check box with the words “Switch blog feed to show excerpts?” next to it.

      Checking the box and clicking save will switch the home blog feed to show excerpts instead of the full content for each post.

      Regards,
      Zulf

Leave a Reply

Your email address will not be published. Required fields are marked *